Auto-PCC pppoe斷線自動修改pcc脚本

:global assign
:global new
:global status
:global x
:gl y
:gl z
:set x 6
:set z -1
:for i from=1 to=$x do={
:set status [/interface get [/interface find name=(“pppoe-out” . $i)] running]
:if ($status=true) do={
:set y [:len [/interface pppoe-client find running=yes]]
:set z ($z+1)
/ip fir man en [find comment=$i]
/ip fir man set [find comment=$i] per-connection-classifier=(“both-addresses:”.$y.”/”.$z)
#:put (“OK Running!”.$y)
#:set new [/ip address get [/ip address find dynamic=yes interface=(“pppoe-out” . $i)] address]
#:set new [:pick $new 0 ([:len $new] -3)];\
# /interface set [find name=(“wan” . $i)] comment=(“\CD\E2\CD\F8” . $i . “\B2\A6\BA\C5\B3\C9\B9\A6!IP: ” . $new)
} \
#else={:put (“NO runing plese check! ” . $i)}
else={/ip fir man dis [find comment=$i]}
}

 

本篇發表於 RouterOS。將永久鏈結加入書籤。

Auto-PCC pppoe斷線自動修改pcc脚本 有 1 則回應

  1. 通告: 首頁 | MikroTik-元芳

發佈留言

發佈留言必須填寫的電子郵件地址不會公開。 必填欄位標示為 *