為你的RouterOS 設定NAT loopback (Hairpin NAT)

如果你的電腦在路由器底下想要透過公網IP或是網址訪問同一個區網底下伺服器的話,

這時因為NAT loopback問題會導致你無法訪問你的區網內的伺服器.

底下是官網的教學,叫作 Hairpin NAT

設定方式如下..

1.假設你的網段是192.168.88.xxx

2.假設你的WEB伺服器是192.168.88.8

底下這張圖第0行是基本的port mapping,就不另外多解釋.

/ip firewall nat
add chain=dstnat in-interface=pppoe-out1 protocol=tcp dst-port=80 \
  action=dst-nat to-address=192.168.88.8 to-port=80
add chain=srcnat out-interface=pppoe-out1 action=masquerade

防火牆第1行開始做起(底下5900改成你自己需要的PORT,例如80)

/ip firewall nat
add chain=dstnat dst-address-type=local protocol=tcp dst-port=80 \
  action=dst-nat to-address=192.168.88.8 to-port=80


第三行的設定(底下5900改成你自己需要的PORT,例如80)

/ip firewall nat add chain=srcnat src-address=192.168.88.0/24 \ dst-address=192.168.88.8 protocol=tcp dst-port=80 \ out-interface=bridge-local action=masquerade

大功告成.

底下這個網址可以自行測試設定是否有成功

https://www.yougetsignal.com/tools/open-ports/

本篇發表於 RouterOS。將永久鏈結加入書籤。

為你的RouterOS 設定NAT loopback (Hairpin NAT) 有 2 則回應

  1. 通告: RouterOS 教學索引 | Mikrotik元芳

發佈留言

發佈留言必須填寫的電子郵件地址不會公開。 必填欄位標示為 *